Skip to main content

CVE-2019-0194

Severity

7.5

Description

Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Mitigation

We recommend upgrading to a version of this component that is not vulnerable to this specific issue.

Project

Apache ActiveMQ

Category
Directory Traversal
Tags
data
Date Disclosed

2019-04-30

Date Discovered

2018-11-14

Apache ActiveMQ 5.15.x

First release:
2017-06-27
CVEs:
24
Support Lifecycle:
Namespace:
javax

Apache ActiveMQ 5.14.x

First release:
2016-08-02
CVEs:
23
Support Lifecycle:
Namespace:
javax

Apache ActiveMQ 5.13.x

First release:
2015-11-30
CVEs:
22
Support Lifecycle:
Namespace:
javax
Feel Vulnerable? 

Contact us so we can help you.

* These fields are required.