Skip to main content

CVE-2015-1796

Severity

4.3

Description

The PKIX trust engines in Shibboleth Identity Provider before 2.4.4 and OpenSAML Java (OpenSAML-J) before 2.6.5 trust candidate X.509 credentials when no trusted names are available for the entityID, which allows remote attackers to impersonate an entity via a certificate issued by a shibmd:KeyAuthority trust anchor.

Mitigation

We recommend upgrading to a version of this component that is not vulnerable to this specific issue. If upgrading is not feasible, follow the workaround(s) stated on the reference pages.

Reference(s):
[https://wiki.shibboleth.net/confluence/display/SHIB2/20150225+Security+Advisory+Examples](https://wiki.shibboleth.net/confluence/display/SHIB2/20150225+Security+Advisory+Examples)
[https://shibboleth.net/community/advisories/secadv_20150225.txt](https://shibboleth.net/community/advisories/secadv_20150225.txt)

Project

Apache TomEE

Category
n/a
Tags
data
Date Disclosed

2015-07-08

Date Discovered

2015-02-17

Apache TomEE 1.7.x

First release:
2014-08-09
CVEs:
87
Support Lifecycle:
Namespace:
javax

Apache TomEE 1.6.x

First release:
2013-11-17
CVEs:
101
Support Lifecycle:
Namespace:
javax

Apache TomEE 1.5.x

First release:
2012-09-28
CVEs:
111
Support Lifecycle:
Namespace:
javax

Apache TomEE 1.0.x

First release:
2012-04-27
CVEs:
121
Support Lifecycle:
Namespace:
javax
Feel Vulnerable? 

Contact us so we can help you.

* These fields are required.